Indicates that there is no Ruby on Rails version installed that satisfies a given Ruby on Rails Gem version specification.

Methods
Attributes
[R] gem_version_spec
Public Class methods
new(message, gem_version_spec)
  • message: The exception message.
  • gem_version_spec: The Ruby on Rails Gem version specification that caused this error.
    # File lib/passenger/exceptions.rb, line 28
28:         def initialize(message, gem_version_spec)
29:                 super(message)
30:                 @gem_version_spec = gem_version_spec
31:         end